65 lines
2.3 KiB
Diff
65 lines
2.3 KiB
Diff
Description: Disable automatic git revision
|
|
The values are defined in debian/rules
|
|
Author: Andrea Pappacoda <andrea@pappacoda.it>
|
|
Forwarded: not-needed
|
|
Last-Update: 2022-12-20
|
|
|
|
--- yuzu-0-1277+ds.orig/CMakeModules/GenerateSCMRev.cmake
|
|
+++ yuzu-0-1277+ds/CMakeModules/GenerateSCMRev.cmake
|
|
@@ -1,56 +1,4 @@
|
|
# SPDX-FileCopyrightText: 2019 yuzu Emulator Project
|
|
# SPDX-License-Identifier: GPL-2.0-or-later
|
|
|
|
-# Gets a UTC timstamp and sets the provided variable to it
|
|
-function(get_timestamp _var)
|
|
- string(TIMESTAMP timestamp UTC)
|
|
- set(${_var} "${timestamp}" PARENT_SCOPE)
|
|
-endfunction()
|
|
-
|
|
-# generate git/build information
|
|
-include(GetGitRevisionDescription)
|
|
-if(NOT GIT_REF_SPEC)
|
|
- get_git_head_revision(GIT_REF_SPEC GIT_REV)
|
|
-endif()
|
|
-if(NOT GIT_DESC)
|
|
- git_describe(GIT_DESC --always --long --dirty)
|
|
-endif()
|
|
-if (NOT GIT_BRANCH)
|
|
- git_branch_name(GIT_BRANCH)
|
|
-endif()
|
|
-get_timestamp(BUILD_DATE)
|
|
-
|
|
-# Generate cpp with Git revision from template
|
|
-# Also if this is a CI build, add the build name (ie: Nightly, Canary) to the scm_rev file as well
|
|
-set(REPO_NAME "")
|
|
-set(BUILD_VERSION "0")
|
|
-set(BUILD_ID ${DISPLAY_VERSION})
|
|
-if (BUILD_REPOSITORY)
|
|
- # regex capture the string nightly or canary into CMAKE_MATCH_1
|
|
- string(REGEX MATCH "yuzu-emu/yuzu-?(.*)" OUTVAR ${BUILD_REPOSITORY})
|
|
- if ("${CMAKE_MATCH_COUNT}" GREATER 0)
|
|
- # capitalize the first letter of each word in the repo name.
|
|
- string(REPLACE "-" ";" REPO_NAME_LIST ${CMAKE_MATCH_1})
|
|
- foreach(WORD ${REPO_NAME_LIST})
|
|
- string(SUBSTRING ${WORD} 0 1 FIRST_LETTER)
|
|
- string(SUBSTRING ${WORD} 1 -1 REMAINDER)
|
|
- string(TOUPPER ${FIRST_LETTER} FIRST_LETTER)
|
|
- set(REPO_NAME "${REPO_NAME}${FIRST_LETTER}${REMAINDER}")
|
|
- endforeach()
|
|
- if (BUILD_TAG)
|
|
- string(REGEX MATCH "${CMAKE_MATCH_1}-([0-9]+)" OUTVAR ${BUILD_TAG})
|
|
- if (${CMAKE_MATCH_COUNT} GREATER 0)
|
|
- set(BUILD_VERSION ${CMAKE_MATCH_1})
|
|
- endif()
|
|
- if (BUILD_VERSION)
|
|
- # This leaves a trailing space on the last word, but we actually want that
|
|
- # because of how it's styled in the title bar.
|
|
- set(BUILD_FULLNAME "${REPO_NAME} ${BUILD_VERSION} ")
|
|
- else()
|
|
- set(BUILD_FULLNAME "")
|
|
- endif()
|
|
- endif()
|
|
- endif()
|
|
-endif()
|
|
-
|
|
configure_file(scm_rev.cpp.in scm_rev.cpp @ONLY)
|