yuzu-Ubuntu/debian/patches/debian-git-revision.patch
Andrea Pappacoda ab56afef99 Import Debian changes 0-1176+ds-1
yuzu (0-1176+ds-1) unstable; urgency=low
.
  * Initial release. Closes: #947399
2022-09-23 13:40:54 +02:00

24 lines
768 B
Diff

Description: Disable automatic git revision
The values are defined in debian/rules
Author: Andrea Pappacoda <andrea@pappacoda.it>
Forwarded: not-needed
Last-Update: 2022-04-29
--- yuzu-0-999+dfsg.orig/CMakeModules/GenerateSCMRev.cmake
+++ yuzu-0-999+dfsg/CMakeModules/GenerateSCMRev.cmake
@@ -6,6 +6,7 @@ endfunction()
list(APPEND CMAKE_MODULE_PATH "${SRC_DIR}/externals/cmake-modules")
+if (False)
# Find the package here with the known path so that the GetGit commands can find it as well
find_package(Git QUIET PATHS "${GIT_EXECUTABLE}")
@@ -53,6 +54,7 @@ if (BUILD_REPOSITORY)
endif()
endif()
endif()
+endif()
# The variable SRC_DIR must be passed into the script
# (since it uses the current build directory for all values of CMAKE_*_DIR)